Player requirements

Sonic Foundry recommends the following system requirements for the best presentation viewing experience with Mediasite Player on Microsoft® Windows, Apple® Mac® OS, Linux® as well as iPad® , iPhone®/iPod®, Android™, and BlackBerry® mobile devices.

Before you begin, here are some things to consider:

  • Playback speed control is only supported on some playback platforms, depending on the player layout, browser type and media playback element.
  • If you are unable to play the presentation, contact your Mediasite administrator to make sure that the appropriate media type is available and supported for your playback platform. Additionally, have your Mediasite administrator verify HTTP streaming is enabled on the Windows Media Server on port 80.
  • Remember to configure pop-up blockers to allow site pop-ups. Otherwise, presentations will not appear. Also, if you are not using Internet Explorer as your browser on Windows, there are additional considerations.

Windows requirements

  • Microsoft Windows 8, Windows 2008 R2, Windows 2008, Windows 7, or Windows Vista
  • Microsoft Internet Explorer® 7.0 or later (including Internet Explorer 10 and 11 on Windows 8), Firefox®, or Google™ Chrome
  • Windows Media® Player 9.0 or later
  • Microsoft Silverlight® 5
  • Broadband Internet connection

Top

Mac requirements

  • Apple Mac OS X 10.5.7 or later
  • Apple Safari™, Firefox, or Chrome
  • Microsoft Silverlight 5
  • Broadband Internet connection

Top

Linux requirements (on-demand playback only)

  • OpenSUSE® or Ubuntu® with the following:
    • FFmpeg plugin
    • Chromium web browser
  • Broadband Internet connection

Note: Mediasite will no longer support playback of Windows Media Format on the Linux platform. Instead, Mediasite will support on-demand presentation playback of H.264 content packaged as MP4. You will need to install the codecs required for H.264 content playback. In addition, you must use a browser that supports H.264 codecs with the HTML5 media element. For more information, go here.

Top

iPad requirements

  • iPad (2nd generation and above)
  • iOS 6.1 or later
  • Apple Mobile Safari™
  • Wi-Fi or cellular data connection (3G or higher)

Top

iPhone/iPod requirements

  • iPhone 4 or later, iPod Touch 4th generation or later
  • iOS 6.1 or later
  • Apple Mobile Safari
  • Mediasite Mobile app (free download available from the Apple App Store)
  • Wi-Fi connection

Top

Android requirements (on-demand playback only)

  • Android™ 4.0 or later
  • Chrome browser
  • Wi-Fi or cellular data connection (3G or higher)

Top

BlackBerry requirements(on-demand playback only)

  • BlackBerry devices running BlackBerry OS 10.0 or later
  • PlayBooks™ devices running QNX
  • BlackBerry browser
  • Wi-Fi or cellular data connection (3G or higher)

Top

Additional considerations

To view Mediasite presentations using Firefox over Windows Vista:

  • Use the ActiveX Plug-in you are prompted to download when you first attempt to view a presentation.


  • OR

  • Copy the Windows XP plug-in dlls to your machine following these instructions.

Top